1. Написать программу, которая подсчитывает количество, сумму и среднее арифметическое положительных чисел последовательности. Размер последовательности определяет сам пользователь программы.
2. Написать программу, которая подсчитывает сумму и количество чисел последовательности, делящихся на 8 без остатка. Размер последовательности определяет сам пользователь программы. Принять, что последовательность состоит только из целых положительных чисел.
Answers & Comments
summa,Shet,a,b,c:integer;
SAP:real;
L:array [1..999] of integer;
begin
Write('Сколько чисел? ');
read(a);
for b:=1 to a do begin
write('Введите число' );
read(c);
if (c>0) then begin Shet:=Shet+1; summa:=summa+c; SAP:=SAP+c; end;
end;
SAP:=SAP/Shet;
Writeln(' Сумма = ',summa,' Сред = ',SAP:5:5,' Количество = ',Shet);
read(a);
end.