1. Напишите программу в паскале!!!!
Красная Шапочка часто навещает свою бабушку. Но она очень боится, что рано или поздно ее бабушку опять навестит волк. Поэтому она решила договориться с Лесничим об охране бабушки. Лесничий согласился охранять бабушку за 10 пирожков.
Узнав об этом, волк сказал Красной Шапочке, что ей совершенно незачем тратить пирожки на Лесничего. За половину тех пирожков, которые Красная Шапочка несет бабушке, Волк пообещал не трогать ее.
26 ноября в России отмечается день матери. Мама испекла несколько пирожков, и попросила Красную Шапочку отнести их бабушке. Требуется определить, какое максимальное количество пирожков Красная Шапочка сможет донести до бабушки.
Входные данные
Вводится одно четное натуральное число, не превосходящее 1000 — количество пирожков, которые испекла мама.
Выходные данные
Программа должна вывести одно число — максимальное количество пирожков, которые Красная Шапочка сможет донести до бабушки.
Примеры
входные данные
12
выходные данные
6
входные данные
100
выходные данные
90
входные данные
20
выходные данные
10
Answers & Comments
Ответ:
program z1;
var k:integer;
begin
readln(k);
if k-10 > k/2 then write(k-10)
else write(k/2)
end.
Объяснение:
У Красной шапочки есть выбор кому давать взятку Лесничему или Волку.
Если она дает взятку Лесничему, то принесет бабушке на 10 пирожков меньше.
k - количество пирожков, которые испекла мама
k - 10 - количество пирожков, которые принесет бабушке Красная шапочка, если даст взятку Лесничему
Если она дает взятку Волку, то принесет бабушке половину пирожков .
k - количество пирожков, которые испекла мама
k / 10 - количество пирожков, которые принесет бабушке Красная шапочка, если даст взятку Волку
Задача - принести максимальное количество пирожков
Сравним k - 10 и k / 10 и решим кому давать взятку