1. Составить программу для нахождения корней приведённого квадратного уравнения с использованием уравнений Виета. На входе - коэффициенты уравнения, на выходе - корни.
2. Составить программу, определяющую, какой четверти декартовой системы координат принадлежит точка (х, у). На на входе - координаты точки, а на выходе - номер четверти
Answers & Comments
Ответ:
Объяснение:
var a,b,c: real;
x1,x2,D: real;
begin
readln(a,b,c);
D := b*b - 4*a*c;
if D<0 then
writeln('Корней нет')
else if D=0 then begin
x1 := -b/2/a;
writeln('x1=x2=',x1);
end
else begin
x1 := (-b-sqrt(D))/2/a;
x2 := (-b+sqrt(D))/2/a;
writeln('x1=',x1,' x2=',x2);
end;