1)Составьте программу, которая заполняет массив а[1.. 10] случайными числами в диапазоне от 0 до 10, затем первый элемент меняет местами с максимальным элементом. Выведите на экран исходный и полученный массивы.
2) Составьте программу, которая вычисляет средний балл по информатике в классе. Количество учеников и четвертые отметки каждого из них введите с клавиатуры.
Программы делаются в паскале. Пожалуйста очень надо полный завал в четверти
Answers & Comments
Verified answer
1.const n=10;
var a:array[1..n] of integer;
max,imax,i:integer;
begin
Randomize;
for i:=1 to n do begin
a[i]:=random(11);
write(a[i],' ');
end;
writeln;
max:=a[1]; imax:=1;
for i:=2 to n do
if a[i]>max then begin max:=a[i]; imax:=i; end;
writeln('max = ',max,' imax = ',imax);
a[imax]:=a[1];
a[1]:=max;
for i:=1 to n do write(a[i],' ');
writeln;
end.
Пример:
6 9 0 2 10 3 0 10 8 2
max = 10 imax = 5
10 9 0 2 6 3 0 10 8 2
2.
var x : array[1..50] of integer;
n,i,s : integer;
begin
write('n = ');
readln(n);
writeln('Введите оценки:');
for i:=1 to n do begin
write('x[',i,']=');
readln(x[i]);
end;
writeln;
s:=0;
for i:=1 to n do s:=s+x[i];
writeln('Средний балл = ',s/n:5:2);
end.
Пример:
n = 5
Введите оценки:
x[1]=4
x[2]=5
x[3]=3
x[4]=4
x[5]=5
Средний балл = 4.20