1. Найдите ошибки в записи операторов присваивания:
Var g, h:Byte;
f:Real;
c, q:Char;
b,e:Boolean;
Begin
g:=5.67;
f:=g+3.789;
c:=’t’;
b:=true;
e:=h>10;
q:=c
End.
2. Найдите неверные операторы присваивания, если y – вещественного, а
n– натурального типа:
a) y:=n+1;
b) n:=y-1;
c) n:=4.0;
d) y:=trunc(y);
e) y:=n div 2;
f) y:=y div 2;
g) n:=n/2;
h) n:=sqr(sqrt(n)).
3. Составить программу, вычисляющую длину окружности и площадь
круга радиуса 5,6 см.
Answers & Comments
1.
Ошибка
g:=5.67;
Присвоение переменной типа byte вещественного значения.
2.
Ошибки
b) n:=y-1; непреводимые типы
n должен быть real
c) n:=4.0; непреводимые типы
n должен быть real
e) y:=n div 2;
y должен быть натурального типа
f) y:=y div 2;
y должен быть натурального типа
g) n:=n/2;
n должен быть real
h) n:=sqr(sqrt(n))
n должен быть real
3.
var r:real;
begin
r:=5.6;
writeln('Вычисление длины круга и площади окружности R》',r);
writeln('Длина окружности》',2*Pi*r);
write('Площадь круга》' ,Pi*Sqr(r))
end.