20 БАЛЛОВ ПОМОГИТЕ ПОЖАЛУЙСТА!!! Задание 1:
В программе «:=» обозначает оператор присваивания, знаки «+», «-», «*» и «div» — соответственно
операции сложения, вычитания, умножения и частное от деления с остатком. Правила выполнения операций и порядок действий соответствуют правилам арифметики. Определите значение целочисленных переменных х и у после выполнения фрагмента программы:
х := 19
у := 3
z := у*2
у := х div у
х := х-z
у := у+z
Задание 2:
Определите, что будет напечатано в результате работы следующего фрагмента программы:
var n, s: integer;
begin
n := 0;
s := 0;
while s <=365 do begin
s := s + 36;
n := n + 10
end;
write(n)
end.
Задание 3:
В программе описан одномерный целочисленный
массив с индексами от 0 до 10. В приведенном ниже фрагменте программы массив
сначала заполняется, а потом изменяется:
for i:=0 to 10 do
A[i]:=i + 1;
for i:=10 downto 0 dо
A[i]:=A[10-i];