Простой калькулятор
ограничение по времени на тест 2 секунды
ограничение по памяти на тест 64 мегабайта
ввод стандартный ввод
вывод стандартный вывод
Даны вещественные числа A и B. Выведите их сумму, разность, произведение и частное.
Входные данные
Ввод содержит вещественные числа A и B ( - 100 ≤ A, B ≤ 100, B ≠ 0), заданные с 2 знаками после запятой.
Выходные данные
В первой строке выведите A + B = X, где X — значение суммы A и B.
Во второй строке выведите A - B = X, где X — значение разности A и B.
В третьей строке выведите A * B = X, где X — значение произведения A и B.
В четвёртой строке выведите A / B = X, где X — значение частного от деления A на B.
Все числа следует выводить с двумя знаками после запятой. Примеры входные данные 1.00 2.00 выходные данные A + B = 3.00 A - B = -1.00 A * B = 2.00 A / B = 0.50 входные данные 35.25 4.42 выходные данные A + B = 39.67 A - B = 30.83 A * B = 155.81 A / B = 7.98
Язык на выбор:
C++ (Visual C++ 2010)
C# .NET (Visual C# 2010)
Pascal (Free Pascal 3.0.0)
Pascal (PascalABC.NET 3.2)
Python (Python 3.2.5)
Java (Java Development Kit 1.7)
Answers & Comments
Код на языке C++ (Я использовал форматированные ввод и вывод):
#include <iostream>
#include <stdio.h>
using namespace std;
int main()
{
float A, B;
printf("Введите числа\n");
scanf("%f %f", &A, &B);
if (A < -100 || (B > 100 && B == 0)){
printf("Ошибка ввода (3)");
return 3;
}
printf("A + B = %.2f", A+B);
printf("A - B = %.2f", A-B);
printf("A * B = %.2f", A*B);
printf("A / B = %.2f", A/B);
return 0;
}
PascalABC.NET: