C++
1) Заполните массив случайными числами и переставьте соседние элементы, поменяв 1-ый
элемент со 2-м, 3-й – с 4-м и т.д.
2) Напишите программу, которая находит максимальный и минимальный из чётных положи-
тельных элементов массива. Если в массиве нет чётных положительных элементов, нужно
вывести сообщение об этом.
Answers & Comments
#include <random>
using namespace std;
typedef size_t _u32;
mt19937 gen { random_device()() };
uniform_int_distribution<> uid(-9, 9);
int main()
{
const _u32 N = 5;
int a[N];
for (_u32 i = 0; i < N; ++i) {
a[i] = uid(gen);
cout << a[i] << " ";
}
cout << endl;
// 1 задание
for (_u32 i = 0; i < N; ++i) {
if (i != N - 1) swap(a[i], a[i + 1]);
cout << a[i] << " ";
}
cout << endl;
// 2 задание
_u32 max = 0, min = INT_MAX;
for (_u32 i = 0; i < N; ++i) {
if ((a[i] % 2 == 0) && (a[i] > 0)) {
if (a[i] > max) max = a[i];
if (a[i] < min) min = a[i];
}
}
cout << max << endl;
cout << min << endl;
}