№ 1. Чему будет равно значение переменной c в результате выполнения фрагмента программы:
a:=125; b:=25; c:=12; if a div 25=0 then
if a mod 12=0 then c:=b div (a mod c)
else c:=a div (b mod c);
1) 0; 2) 1; 3) 12; 4) 125.
№ 2. Определите значение переменных s и i после выполнения следующих операторов:
s := 0;
i := 0;
while i < 5 do
beign
i := i + 1;
s := s + 1;
end;
№ 5 Для генерации случайного целого числа из интервала [10, 20) необходимо использовать выражение:
random*20 2) random (20) 3) random (10)+10 4) random (10)*2
№ 6 Три из приведенных ниже арифметических выражений соответствуют одной и той же формуле, а одно – другой формуле. Найдите это «лишнее» выражение.
1) A*B/C*D/E
B/E/C*(A*D)
(A*B)/(C*D)/E
A*B*D/C/E
№ 7 Укажите тип синтаксической ошибки, имеющейся в данной программе на Паскале:
Program a2;
Var b2, 2c: real;
Begin
read(b2);
2c:=b2*b2
End.
Ответ: _____________________________________________________________________
№ 8 Дан оператор цикла на языке Паскаль:
A:=0;
for I:=1 to 10 do
begin
A:=A+12;
writeln(A+I,I);
end;
Чему будет равно последнее значение I, выведенное на экран?
Ответ: _________________________
№ 9 Выбрать фрагмент программы на языке программирования Паскаль, в котором вычисляется
значение функции:
1) if X > –5 then
begin if X < 5
then Y:=0
else Y:=1;
end;
2) if X > –5
then if X < 5
then Y:=0;
Y:=1;
Y:=1;
3) if X > –5
then if X < 5
then Y:=0;
4) if X > –5
then Y:=0
else Y:=1;
if X < 5 then Y:=1;
№ 10 Выражение
a/b + (c+d)-(a-b)/b/c+0.11,
записанное на языке Паскаль, математически может быть записано как...
Answers & Comments
2-вообще, программа составлена неверно(being), но если не считать этого, то i=s=5
5-3
6-(A*B)/(C*D)/E
7-не указан символ ";" после команды 2c:=b2*b2
8-10
9-4
10-(ac+bc^2-bcd-a+b^2)/(bc)+0.11