Цикл с параметром.Pascale.Нужно написать программу. Определить количество чисел, кратных 5, среди N чисел, заданных случайным образом в диапозоне от -50 до 50.
Answers & Comments
Mishka28
Const nmax = 30; var a:array [1..nmax] of integer; i,k,n:integer; begin randomize; k:=0; repeat write ('N = '); readln (n); until n in [1..nmax]; for i:=1 to n do begin a[i]:=random(101)-50; writeln (a[i]); if a[i] mod 5 = 0 then inc(k); end; writeln ('Kol-vo: ',k); end.
Answers & Comments
var a:array [1..nmax] of integer;
i,k,n:integer;
begin
randomize;
k:=0;
repeat
write ('N = ');
readln (n);
until n in [1..nmax];
for i:=1 to n do
begin
a[i]:=random(101)-50;
writeln (a[i]);
if a[i] mod 5 = 0 then inc(k);
end;
writeln ('Kol-vo: ',k);
end.