Дана последовательность n элементов. Написать программу которая прдсчитает сумму элементов этой последовательности.
Answers & Comments
srzontmp
Const m = 100; var i,n,s: integer; a: array[1..m] of integer; begin write('размер массива: '); readln(n); randomize; s:=0; writeln('исходный массив: '); for i:=1 to n do begin a[i]:=random(-50,50); write(a[i],' '); s:=s+a[i]; end; writeln; writeln('сумма элементов: ',s); end.
Answers & Comments
var i,n,s: integer;
a: array[1..m] of integer;
begin
write('размер массива: '); readln(n);
randomize;
s:=0;
writeln('исходный массив: ');
for i:=1 to n do
begin
a[i]:=random(-50,50);
write(a[i],' ');
s:=s+a[i];
end;
writeln;
writeln('сумма элементов: ',s);
end.
размер массива: 15
исходный массив:
20 -20 8 -8 25 42 1 38 -31 17 30 2 -6 -43 35
сумма элементов: 110