Home
О нас
Products
Services
Регистрация
Войти
Поиск
Zpok
@Zpok
July 2022
1
10
Report
дано четырехзначное число. Написать программу, которая определяет максимальную цифру числа
C++
Please enter comments
Please enter your name.
Please enter the correct email address.
Agree to
terms of service
You must agree before submitting.
Send
Answers & Comments
AnonimusPro
Verified answer
#include <iostream>
using namespace std;
int main()
{
int max=0;
int temp,n;
cin>>n;
while(n>0)
{
temp=n%10;
if(temp>=max) {max=temp;}
n=n/10;
}
cout<<max<<endl;
}
2 votes
Thanks 1
More Questions From This User
See All
Zpok
August 2022 | 0 Ответы
Буклет о выставке детского творчества состоит из 520 страниц. Часть страниц соде...
Answer
Zpok
August 2022 | 0 Ответы
Пояснение: команда break - принудительно завершает цикл.C++...
Answer
Zpok
August 2022 | 0 Ответы
Напишите программу, которая получает три числа – рост трёх спортсменов, и выводи...
Answer
Zpok
August 2022 | 0 Ответы
Напишите программу, которая в последовательности целых чисел определяет количест...
Answer
Zpok
August 2022 | 0 Ответы
Железная дорога При строительстве новой железной дороги возникли проблемы. Дорог...
Answer
Zpok
August 2022 | 0 Ответы
Дано четыре целых числа. Возвести в квадрат те из них, значения которых неотрица...
Answer
Zpok
August 2022 | 0 Ответы
i; i--; }C++...
Answer
Zpok
August 2022 | 0 Ответы
В массиве хранится информация о росте 25 человек. Определить, на сколь-ко рост с...
Answer
Zpok
August 2022 | 0 Ответы
В массиве хранится информация о росте 25 человек. Определить, на сколь-ко рост с...
Answer
Zpok
August 2022 | 0 Ответы
Задача 4. Паронимы Паронимы - это слова, различающиеся лексическим значением, но...
Answer
рекомендуемые вопросы
rarrrrrrrr
August 2022 | 0 Ответы
о чем должны позаботиться в первую очередь взрослые при организационном вывозе н...
danilarsentev
August 2022 | 0 Ответы
Есть два станка на которых выпускают одинаковые запчасти один производит a запча...
myachina8
August 2022 | 0 Ответы
Найти по графику отношение V3:V1. В ответах написано 9, но нужно решение...
ydpmn7cn6w
August 2022 | 0 Ответы
Choose the correct preposition: 1.I am fond (out,of,from) literature. 2.where ar...
millermilena658
August 2022 | 0 Ответы
Определите Как создавалась и кто создавал арабское государство в крации...
MrZooM222
August 2022 | 0 Ответы
Ч. Айтманов в рассказе "Красное яблоко" использует метод рассказ в рассказе. Опи...
timobila47
August 2022 | 0 Ответы
каково было назначение каждой из частей византийского храма? помогите пожалуйста...
ivanyyaremkiv
August 2022 | 0 Ответы
moment. 6....
Участник Знаний
August 2022 | 0 Ответы
Пожалуйста!!!!!!!!!!!!...
sarvinozwakirjanova
August 2022 | 0 Ответы
помогите пожалусто пж...
×
Report "дано четырехзначное число. Написать программу, которая определяет максимальную ц..."
Your name
Email
Reason
-Select Reason-
Pornographic
Defamatory
Illegal/Unlawful
Spam
Other Terms Of Service Violation
File a copyright complaint
Description
Helpful Links
О нас
Политика конфиденциальности
Правила и условия
Copyright
Контакты
Helpful Social
Get monthly updates
Submit
Copyright © 2025 SCHOLAR.TIPS - All rights reserved.
Answers & Comments
Verified answer
#include <iostream>using namespace std;
int main()
{
int max=0;
int temp,n;
cin>>n;
while(n>0)
{
temp=n%10;
if(temp>=max) {max=temp;}
n=n/10;
}
cout<<max<<endl;
}