Даны три натуральных числа. Напишите программу, определяющую, существует ли треугольник с такими длинами сторон.Если существует такой треугольник, то определите его тип (равносторонний, равнобедренный, разносторонний)
Пример входных данный Пример выходных данных
a b c>> 1 2 1 Не существует a b c>> 2 2 2 Равносторонний
a b c>> 20 20 30 Равнобедренный
a b c>> 3 4 5 Разносторонний

1

что не правильно в моей программе?

program qq;
var a,b,c: integer;
begin
Read (a,b,c);
if (a<>b) and (a<>c) and (c<>b) then
Write ('Треугольник-разносторонний');
if (a=b) or (a=c) or (c=b) then
Write ('Треугольник-равнобедренный');
if (a=b) and (a=c) and (c=b) then
Write ('Треугольник-равносторонний');
if (a Write ('Треугольник-не существует');
end.
Please enter comments
Please enter your name.
Please enter the correct email address.
You must agree before submitting.

Answers & Comments


Copyright © 2025 SCHOLAR.TIPS - All rights reserved.