Даю 30 баллов!!! написать программу для определения количества корней квадратного уравнения по коэффициентам a, b, c
Answers & Comments
kcyxa19941021
// PascalABC.NET 3.1, сборка 1218 от 12.04.2016 begin var a,b,c:real; Writeln('Введите коэффициенты квадратного уравнения (a b c)'); Read(a,b,c); if a=0 then begin Writeln('а=0 делает уравнение линейным'); if b=0 then Writeln('Корней нет') else Writeln('Один корень ') end else begin var d:=b*b-4*a*c; if d<0 then Writeln('Нет действительных корней') else if d=0 then Writeln('Один корень') else Writeln('Два корня') end end.
Answers & Comments
begin
var a,b,c:real;
Writeln('Введите коэффициенты квадратного уравнения (a b c)');
Read(a,b,c);
if a=0 then begin
Writeln('а=0 делает уравнение линейным');
if b=0 then Writeln('Корней нет')
else Writeln('Один корень ')
end
else begin
var d:=b*b-4*a*c;
if d<0 then Writeln('Нет действительных корней')
else
if d=0 then Writeln('Один корень')
else Writeln('Два корня')
end
end.