Даю 45 баллов!!! ТОлько помогите!! Напишите программу которая вводит целое число, не превышающее 100, и выводит его прописью, например, 21→"двадцать один". В Паскале,пожалуйстаааа
Program pr; var st:string; n:integer; begin writeln ('Введите число от 1-го до 100'); readln(n); st:=''; case n of 100:st:=st+'Сто'; 10:st:=st+'Десять'; 11:st:=st+'Одиннадцать'; 12:st:=st+'Двенадцать'; 13:st:=st+'Тринадцать'; 14:st:=st+'Четырнадцать'; 15:st:=st+'Пятнадцать'; 16:st:=st+'Шестнадцать'; 17:st:=st+'Семнадцать'; 18:st:=st+'Восемнадцать'; 19:st:=st+'Девятнадцать'; else begin case n div 10 of 2:st:=st+'Двадцать '; 3:st:=st+'Тридцать '; 4:st:=st+'Сорок '; 5:st:=st+'Пятьдесят '; 6:st:=st+'Шестьдесят '; 7:st:=st+'Семьдесят '; 8:st:=st+'Восемьдесят '; 9:st:=st+'Девяносто '; end; case n mod 10 of 1:st:=st+'один'; 2:st:=st+'два'; 3:st:=st+'три'; 4:st:=st+'четыре'; 5:st:=st+'пять'; 6:st:=st+'шесть'; 7:st:=st+'семь'; 8:st:=st+'восемь'; 9:st:=st+'девять'; end; end; end; writeln(st); end.
Answers & Comments
Verified answer
Program pr;var st:string;
n:integer;
begin
writeln ('Введите число от 1-го до 100');
readln(n);
st:='';
case n of
100:st:=st+'Сто';
10:st:=st+'Десять';
11:st:=st+'Одиннадцать';
12:st:=st+'Двенадцать';
13:st:=st+'Тринадцать';
14:st:=st+'Четырнадцать';
15:st:=st+'Пятнадцать';
16:st:=st+'Шестнадцать';
17:st:=st+'Семнадцать';
18:st:=st+'Восемнадцать';
19:st:=st+'Девятнадцать';
else
begin
case n div 10 of
2:st:=st+'Двадцать ';
3:st:=st+'Тридцать ';
4:st:=st+'Сорок ';
5:st:=st+'Пятьдесят ';
6:st:=st+'Шестьдесят ';
7:st:=st+'Семьдесят ';
8:st:=st+'Восемьдесят ';
9:st:=st+'Девяносто ';
end;
case n mod 10 of
1:st:=st+'один';
2:st:=st+'два';
3:st:=st+'три';
4:st:=st+'четыре';
5:st:=st+'пять';
6:st:=st+'шесть';
7:st:=st+'семь';
8:st:=st+'восемь';
9:st:=st+'девять'; end;
end;
end;
writeln(st);
end.