Даю много баллов,тому кто напишет мне программу и составит блок схему.
На зыке Си напишите программу для определения значения упрощенной функции, полученной в п. 1.1 при различных значениях переменных. Составьте блок-схему алгоритма. Упрощенную функция я прикрепила в фото.
Answers & Comments
Verified answer
Блок-схема - в прилагаемом файле.Программа:
#include <stdio.h>
int main() {
int a,b;
printf(" A B | not A | not B | not A & not B\n");
for (a=0; a<=1; a++)
for (b=0; b<=1; b++) {
printf(" %d %d %5d %7d %11d\n", a, b, !a, !b, !a&&!b);
}
return 0;
}
Результат:
A B | not A | not B | not A & not B
0 0 1 1 1
0 1 1 0 0
1 0 0 1 0
1 1 0 0 0