Для каждой задачи составить программу в Pascal, выводящую значение TRUE, если указанное высказывание является истинным, и FALSE - в противном случае (использовать условный оператор нельзя).
10. В заданном натуральном трехзначном числе N имеется чётная цифра.
11. Сумма каких-либо двух цифр заданного трёхзначного натурального числа N равна третьей цифре.
12. Сумма цифр заданного четырёхзначного числа N превосходит произведение цифр этого же числа на 1.
13. Сумма двух последних цифр заданного трёхзначного числа N меньше заданного K, а первая цифра больше 5.
Ребята, очень прошу, помогите! Срочно!!!
Answers & Comments
Verified answer
// 10.var
n: integer;
begin
read(n);
Write((n div 100 mod 2 = 0) or (n mod 10 mod 2 = 0) or (n mod 100 div 10 mod 2 = 0));
end.
// 11.
var
n: integer;
a,b,c:integer;
begin
read(n);
a:=n div 100; b:=n mod 100 div 10; c:=n mod 10;
Write((a+b=c)or(a+c=b)or(c+b=a));
end.
// 12.
var
n: integer;
a,b,c,d:integer;
begin
read(n);
a:=n div 1000; b:=n mod 1000 div 10 div 10; c:=n mod 100 div 10; d:=n mod 10;
Write(a+b+c+d-1=a*b*c*d);
end.
// 13.
var
n,k: integer;
a,b,c:integer;
begin
Write('n,k= '); read(n,k);
a:=n div 100; b:=n mod 100 div 10; c:=n mod 10;
Write((b+c<k)and(a>5));
end.