Это в Паскале.
Первая задача: Дана последовательность чисел,оканчивающихся отрицательным числом. Найти среднее арифметическое введенных положительных чисел.
И вторая: Дана последовательность чисел,количество которых заранее не известно. Сколько чисел было введено до первого нуля?
Буду очень благодарен,если ответите.
Answers & Comments
var a,n,s: integer;
begin
n := 0;
s := 0;
read(a);
while a >= 0 do
begin
s := s + a;
n := n + 1;
read(a)
end;
write(s/n)
end.
{2}
var a,n: integer;
begin
n := 0;
read(a);
while a <> 0 do
begin
n := n + 1;
read(a)
end;
write(n)
end.