Home
О нас
Products
Services
Регистрация
Войти
Поиск
Tizifona
@Tizifona
July 2022
1
54
Report
Free Pascal. Нужно написать программу, где после каждой буквы Ch вставляется строка Str1.
Please enter comments
Please enter your name.
Please enter the correct email address.
Agree to
terms of service
You must agree before submitting.
Send
Answers & Comments
12w12w
Var
s,str1:string;
ch:char;
i:integer;
begin
Write('Введите текст: '); ReadLn(s);
Write('Введите искомый символ: '); Readln(ch);
Write('Введите добавляемый текст: '); Readln(str1);
for i:=Length(s) downto 1 do
if s[i]=ch then Insert(str1,s,i+1);
Writeln('Результат: ',s);
Readln;
end.
Тестовое решение:
Введите текст: А роза упала на лапу Азора
Введите искомый символ: а
Введите добавляемый текст: 12345
Результат: А роза12345 упа12345ла12345 на12345 ла12345пу Азора12345
1 votes
Thanks 1
More Questions From This User
See All
Tizifona
July 2022 | 0 Ответы
free pascal 15 zadanie
Answer
Tizifona
July 2022 | 0 Ответы
paskal chisla fibonachchi chisla fibonachchi fn opredelyayutsya formulami f0f1f2
Answer
Tizifona
July 2022 | 0 Ответы
paskal 1 dano trehznachnoe chislo nuzhno najti chislo poluchennoe pri prochtenii
Answer
Tizifona
July 2022 | 0 Ответы
free pascal zadat massiv i iz massiva a v b perepisat snachala vse nuli poto
Answer
Tizifona
April 2022 | 0 Ответы
napishite pozhalujsta reakciyu kak iz feso4 poluchit feohso4
Answer
Tizifona
October 2021 | 0 Ответы
v legochnyh kapillyarah proishodit obmen sostava krovi s venoznoj na arterialnuyu
Answer
Tizifona
October 2021 | 0 Ответы
pomogite pozhalujsta s paskalem nuzhno napisat programmu kotoraya modeliruet d
Answer
Tizifona
October 2021 | 0 Ответы
paskal pomogite pozhalujsta nuzhno napisat programmu kotoraya v levom verhnem
Answer
Tizifona
October 2021 | 0 Ответы
paskal podskazhite pozhalujsta kak mozhno usovershenstvovat programmu tak chtob
Answer
Tizifona
October 2021 | 0 Ответы
free pascal najti kolichestvo chetnyh chisel sredi pyati celyh chisel bez ispolzov
Answer
рекомендуемые вопросы
rarrrrrrrr
August 2022 | 0 Ответы
o chem dolzhny pozabotitsya v pervuyu ochered vzroslye pri organizacionnom vyvoze n
danilarsentev
August 2022 | 0 Ответы
est dva stanka na kotoryh vypuskayut odinakovye zapchasti odin proizvodit a zapcha
myachina8
August 2022 | 0 Ответы
najti po grafiku otnoshenie v3v1 v otvetah napisano 9 no nuzhno reshenie
ydpmn7cn6w
August 2022 | 0 Ответы
Choose the correct preposition: 1.I am fond (out,of,from) literature. 2.where ar...
millermilena658
August 2022 | 0 Ответы
opredelite kak sozdavalas i kto sozdaval arabskoe gosudarstvo v kracii
MrZooM222
August 2022 | 0 Ответы
ch ajtmanov v rasskaze krasnoe yabloko ispolzuet metod rasskaz v rasskaze opi
timobila47
August 2022 | 0 Ответы
kakovo bylo naznachenie kazhdoj iz chastej vizantijskogo hrama pomogite pozhalujsta
ivanyyaremkiv
August 2022 | 0 Ответы
moment. 6....
pozhalujsta8b98a56c0152a07b8f4cbcd89aa2f01e 97513
sarvinozwakirjanova
August 2022 | 0 Ответы
pomogite pozhalusto pzha519d7eb8246a08ab0df06cc59e9dedb 6631
×
Report "Free Pascal. Нужно написать программу, где после каждой буквы Ch вставляется стр..."
Your name
Email
Reason
-Select Reason-
Pornographic
Defamatory
Illegal/Unlawful
Spam
Other Terms Of Service Violation
File a copyright complaint
Description
Helpful Links
О нас
Политика конфиденциальности
Правила и условия
Copyright
Контакты
Helpful Social
Get monthly updates
Submit
Copyright © 2024 SCHOLAR.TIPS - All rights reserved.
Answers & Comments
s,str1:string;
ch:char;
i:integer;
begin
Write('Введите текст: '); ReadLn(s);
Write('Введите искомый символ: '); Readln(ch);
Write('Введите добавляемый текст: '); Readln(str1);
for i:=Length(s) downto 1 do
if s[i]=ch then Insert(str1,s,i+1);
Writeln('Результат: ',s);
Readln;
end.
Тестовое решение:
Введите текст: А роза упала на лапу Азора
Введите искомый символ: а
Введите добавляемый текст: 12345
Результат: А роза12345 упа12345ла12345 на12345 ла12345пу Азора12345