Heeeeeelp!!! Памахите!
Напишите программу, которая в последовательности натуральных чисел определяет сумму всех чисел, кратных 6 и оканчивающихся на 2. Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 — признак окончания ввода, не входит в последовательность).
Количество чисел не превышает 100. Введённые числа не превышают 300. Программа должна вывести одно число: сумму всех чисел, кратных 6 и оканчивающихся на 2.
Answers & Comments
Так как конкретный язык программирования не был назван, сделал на Pascal.
program Taksebeuchenic;
var x, k: Integer;
begin
write('В последовательности натуральных чисел определить сумму всех чисел, кратных 6 и оканчивающихся на 2.');
write('Программа получает на вход натуральные числа, количество введённых чисел неизвестно,');
write('последовательность чисел заканчивается числом 0 (0 — признак окончания ввода, не входит в последовательность).');
write('Количество чисел не превышает 100. Введённые числа не превышают 300. Программа должна вывести одно число: сумму всех чисел,');
writeln('кратных 6 и оканчивающихся на 2.');
writeln;
write('Введите x: ');
readln(x);
k := 0;
while (x <> 0) do
begin
if ((x mod 6 = 0) and (x mod 10 = 2)) then k := k + 1;
write('Введите x: ');
readln(x);
end;
writeln(k);
readln;
end.