September 2021 0 17 Report
И снова я, и снова мой любимый Паскаль.. Дан массив, состоящий из целых чисел. Напишите программу, которая подсчитывает количество положительных чисел среди элементов массива.

Входные данные
Сначала задано число N — количество элементов в массиве (1
Выходные данные
Необходимо единственное число - количество положительных элементов в массиве.

Написал:

program u1;
var i,n,k:longint; a:array[1..10000] of longint;
begin
readln(n);
for i:=1 to n do readln (a[i]);
for i:= 1 to n do write( 'a[i]=',a[i],' ');writeln;
for i:= 1 to n do begin
if a[i]>0 then k:=k+1;end;
writeln(k);
end.
но тем не менее, решено не правильно. Пожалуйста, посмотрите.
Please enter comments
Please enter your name.
Please enter the correct email address.
You must agree before submitting.
More Questions From This User See All

Copyright © 2025 SCHOLAR.TIPS - All rights reserved.