Информатика.Паскаль.(10-11 класс)1 курс. Помогите пожалуйста написать программу по теме : " Разработка и отладка программ с циклами " . + Если по этой программе можно сделать график , то сделайте пожалуйста хотя бы примерный.
Answers & Comments
kubanychbekuulubaiys
Var Y,a,x:real; c:Integer; begin read(a); x:=0.5; while x<=4.5 do begin Y:=a+sqr(x); writeln('x:',x:2:2,' Y:',Y:2:2); c:=c+1; x:=x+0.3; end; write('Среднее арифмитическое:',Y/c:2:2); end.
Answers & Comments
c:Integer;
begin
read(a);
x:=0.5;
while x<=4.5 do begin
Y:=a+sqr(x);
writeln('x:',x:2:2,' Y:',Y:2:2);
c:=c+1;
x:=x+0.3;
end;
write('Среднее арифмитическое:',Y/c:2:2);
end.
я думаю что эт правильно