Как в C++ написать программу, чтобы она спрашивала твоё имя, а затем здоровалась с тобой. Я пишу, вроде всё правильно делаю, но программа выдает: "Hello, 0", чтобы я не вводила.
#include ;
using namespace std;
int main() {
int name;
cout << "What is your name?";
cin >> name;
cout << "Hello," << name<< endl;
return 0;
}
Answers & Comments
1) Ты забыл подключить библиотеку <iostream> (надо было наприсать
#include <iostream>)
2) int - тип целочисленных переменных - они могут принимать лишь значения, что не удивительно, целых чисел. Для твоей цели необходимо использовать строковую переменную, в C++ - это string (Для ее использования необходимо ее подключить - #include <string>)
Итого
#include <iostream>
#include <string>
using namespace std;
int main() {
string name;
cout << "What is your name?";
cin >> name;
cout << "Hello, " << name<< endl;
return 0;
}