Home
О нас
Products
Services
Регистрация
Войти
Поиск
innessabest
@innessabest
July 2022
1
91
Report
Написать программу, определяющую сумму/количество элементов массива, кратных 3, но не кратных 5.
на языке С++
Please enter comments
Please enter your name.
Please enter the correct email address.
Agree to
terms of service
You must agree before submitting.
Send
Answers & Comments
clinteastwood2
#include <iostream>
#include <array>
#include <numeric>
using namespace std;
const size_t N = 10;
int main()
{
size_t sum = 0;
array<int, N> a = { 1, 5, 9, 6, 3, 0, 1, 4, -2, 15 };
cout << "Count: ";
cout << accumulate(a.cbegin(), a.cend(), 0, [&sum](size_t count, const int
num) {
if ( !(num % 3) && num % 5 ) {
++count;
sum += num;
}
return count;
});
cout << " Sum: " << sum << endl;
}
0 votes
Thanks 0
More Questions From This User
See All
innessabest
August 2022 | 0 Ответы
Всем привет. Есть программисты? Программа, получает скорость машины, время, кото...
Answer
innessabest
August 2022 | 0 Ответы
Написать две функции: одна из которых осуществляет перевод из десятичной системы...
Answer
innessabest
August 2022 | 0 Ответы
Написать программу, которая предлагает пользователю ввести число, определяет кра...
Answer
innessabest
August 2022 | 0 Ответы
Написать программу, которая предлагает пользователю ввести число, определяет кра...
Answer
innessabest
July 2022 | 0 Ответы
Проверить, состоит ли пятизначное число из цифр, являющихся простыми числами или...
Answer
innessabest
July 2022 | 0 Ответы
Проверить, состоит ли пятизначное число из цифр, являющихся простыми числами или...
Answer
innessabest
July 2022 | 0 Ответы
Получение параметров ямы и количество кубометров воды. Проверка, получится умест...
Answer
innessabest
July 2022 | 0 Ответы
СРОЧНО!!! В программе имеется список имен и соответствующие им буквы и буквы-пар...
Answer
innessabest
July 2022 | 0 Ответы
Пользователь вводит с клавиатуры количество строк и количество столбцов. Програм...
Answer
innessabest
July 2022 | 0 Ответы
В швейное ателье привезли X метров ситца, а шелка привезли на Y метров меньше. С...
Answer
рекомендуемые вопросы
rarrrrrrrr
August 2022 | 0 Ответы
о чем должны позаботиться в первую очередь взрослые при организационном вывозе н...
danilarsentev
August 2022 | 0 Ответы
Есть два станка на которых выпускают одинаковые запчасти один производит a запча...
myachina8
August 2022 | 0 Ответы
Найти по графику отношение V3:V1. В ответах написано 9, но нужно решение...
ydpmn7cn6w
August 2022 | 0 Ответы
Choose the correct preposition: 1.I am fond (out,of,from) literature. 2.where ar...
millermilena658
August 2022 | 0 Ответы
Определите Как создавалась и кто создавал арабское государство в крации...
MrZooM222
August 2022 | 0 Ответы
Ч. Айтманов в рассказе "Красное яблоко" использует метод рассказ в рассказе. Опи...
timobila47
August 2022 | 0 Ответы
каково было назначение каждой из частей византийского храма? помогите пожалуйста...
ivanyyaremkiv
August 2022 | 0 Ответы
moment. 6....
Участник Знаний
August 2022 | 0 Ответы
Пожалуйста!!!!!!!!!!!!...
sarvinozwakirjanova
August 2022 | 0 Ответы
помогите пожалусто пж...
×
Report "количество элементов массива, кратных 3, но не кратных 5. на языке С++..."
Your name
Email
Reason
-Select Reason-
Pornographic
Defamatory
Illegal/Unlawful
Spam
Other Terms Of Service Violation
File a copyright complaint
Description
Helpful Links
О нас
Политика конфиденциальности
Правила и условия
Copyright
Контакты
Helpful Social
Get monthly updates
Submit
Copyright © 2025 SCHOLAR.TIPS - All rights reserved.
Answers & Comments
#include <array>
#include <numeric>
using namespace std;
const size_t N = 10;
int main()
{
size_t sum = 0;
array<int, N> a = { 1, 5, 9, 6, 3, 0, 1, 4, -2, 15 };
cout << "Count: ";
cout << accumulate(a.cbegin(), a.cend(), 0, [&sum](size_t count, const int
num) {
if ( !(num % 3) && num % 5 ) {
++count;
sum += num;
}
return count;
});
cout << " Sum: " << sum << endl;
}