Массив из пяти элементов заполняется натуральными числами. Составить программу, которая определяет сумму элементов массива, кратных трем и заканчивающихся на 7( программа Pascal)
Var a:array[1..5] of integer; i,s:integer; begin writeln('Введите 5 чисел:'); for i:=1 to 5 do begin read(a[i]); if (a[i] mod 3 = 0)and(a[i] mod 10 = 7) then s:=s+a[i]; end; writeln('s = ',s); end.
Answers & Comments
Verified answer
Var a:array[1..5] of integer;i,s:integer;
begin
writeln('Введите 5 чисел:');
for i:=1 to 5 do
begin
read(a[i]);
if (a[i] mod 3 = 0)and(a[i] mod 10 = 7) then s:=s+a[i];
end;
writeln('s = ',s);
end.
Пример:
Введите 5 чисел:
125 273 117 471 207
s = 324