написать программу, которая вычисляет сумму видаs=2/1+3/2+4/3+...+(n+1)/n
Найти ошибки в программе
Program A;
var b,c:real;
begin
readln(b);
if b>=0 then c:=23*d
else c:=d*d;
writeln(‘c=’,c)
end.
А) ожидался символ «;»
Б) ошибка в записи выражения
В) неописанный идентификатор
Г) ошибка в записи оператора
Answers & Comments
Program A;
var b,c:real;
begin
readln(b);
if b>=0 then
c:=23*b
else
c:=b*b;
writeln('c = ', c:0:3);
end.
Правильный код.
Правда у вас есть переменная d, её нет в коде и она не инициализируется, так что я логически заменил её на b