НА c++ ПОЖАЛУЙСТА
Напишите программу, которая вводит номер месяца и выводит название времени года на английском языке. При вводе неверного номера месяца должно быть выведено слово 'NO'.
Входные данные
Входная строка содержит единственное число – номер месяца (возможно, неверный).
Выходные данные
Нужно вывести название времени года (на английском языке), соответствующее введённому номеру месяца ('winter' – зима, 'spring' – весна, 'summer' – лето, 'autumn' – осень). Если введён неверный номер месяца, программы должна вывести слово 'NO'.
Примеры
входные данные
4
выходные данные
spring
Answers & Comments
Verified answer
#include <iostream>using namespace std;
int main()
{
int num;
cin>>num;
if(num==1 || num==2 || num==12)
{cout<<"winter";}
else if (num==3 || num==5 || num==4)
{cout<<"spring";}
else if (num==6 || num==7 || num==8)
{cout <<"summer";}
else if(num==9 || num==10 || num==11)
{cout<<"autumn";} else cout<<"no";
return 0;
}
int main()
{
int a;
scanf("d",&a);
if(a==1 || a==2 || a==12)
printf("zima/n");
if (a==3 || a==5 || a==4)
printf("spring/n");
if (a==6 || a==7 || a==8)
printf("summer/n");
if(a==9 || a==10 || a==11)
printf("autumn") ;else printf("no");
}