На с++ и несложно, пожалуйста
Подсчитайте за один проход массива, сколько его элементов равны максимальному элементу.
Входные данные
На вход программе сначала подается значение n100 — количество элементов в массиве. В следующей строке входных данных расположены сами элементы массива — целые числа, по модулю не превосходящие 30 000.
Выходные данные
Выдайте количество искомых элементов массива.
Примеры
входные данные
8
4 3 5 2 5 1 3 5
выходные данные
3
Answers & Comments
#include <iostream>
using namespace std;
int main(){
int n,maks,schetchik;
cin >>n;
if(n<=100){
int a[n];
for(int i=0;i<n;i++){
cin >> a[i];
if (a[i]>-30000 && a[i]<30000){
if(i==0){maks=a[i]; schetchik =1;};
if (i!=0 && maks == a[i]) {schetchik +=1;};
if (maks<a[i]) {maks = a[i]; schetchik = 1; };
}
}
cout << schetchik; }
}
#include <iostream>
int main()
{
int *arr, size, max = -30000, nMax = 0;
std::cin >> size;
arr = new int[size];
for (int i = 0; i < size; i++)
{
std::cin >> arr[i];
if (arr[i] > max)
max = arr[i], nMax = 1;
else if (arr[i] == max)
nMax++;
}
std::cout << nMax;
delete[] arr;
return 0;
}