на с++ с оператором switch
Работа светофора для водителей запрограммирована следующим образом: начиная с начала каждого часа, в течение трёх минут горит зелёный сигнал, затем в течение одной минуты — жёлтый, в течение двух минут — красный, в течение трёх минут — опять зелёный и т.д.
Дано число t, означающее время в минутах, прошедшее с начала очередного часа. Определите, сигнал какого цвета горит для водителей в этот момент.
Формат входных данных
Вводится целое число t (0≤t≤59).
Формат выходных данных
Требуется вывести «RED», «YELLOW» или «GREEN» для красного, желтого или зелёного цвета светофора соответственно.
Примеры
входные данные выходные данные
3
YELLOW
10
RED
Answers & Comments
#include <iostream>
using std::cin;
using std::cout;
int main() {
int t;
cin >> t;
switch (t%6) {
case 5: case 4:
cout << "RED\n";
break;
case 3:
cout << "YELLOW\n";
break;
case 2: case 1: case 0:
cout << "GREEN\n";
break;
}
return 0;
}