Надо составить программу. Дана последовательность натуральных чисел а1, а2, ... аn. Создать массив из нечетных чисел этой последовательности если таких нет, выведите сообщение об этом факте. СРОЧНО НАДО СЕГОДНЯ((((
Answers & Comments
VlaNik
Var m:array [1..10000] of integer; a,n,i,j:integer; begin writeln('Введите n:'); readln(n); j:=0; writeln('Введите последовательность чисел:'); for i:=1 to n do begin readln(a); if (a mod 2)<>0 then begin j:=j+1; m[j]:=a; end; end; if j=0 then writeln ('Нечетных чисел нет в данной последовательности.') else begin writeln ('Нечетные числа в данной последовательности:'); for i:=1 to j do write(m[i],' '); writeln; end; end.
Answers & Comments
m:array [1..10000] of integer;
a,n,i,j:integer;
begin
writeln('Введите n:');
readln(n);
j:=0;
writeln('Введите последовательность чисел:');
for i:=1 to n do
begin
readln(a);
if (a mod 2)<>0 then begin j:=j+1; m[j]:=a; end;
end;
if j=0 then writeln ('Нечетных чисел нет в данной последовательности.')
else
begin
writeln ('Нечетные числа в данной последовательности:');
for i:=1 to j do
write(m[i],' ');
writeln;
end;
end.