Найти произведение всех чётных чисел от 1 до 50. Написать программу, которая решила бы эту задачу.
Answers & Comments
Maximason
Uses crt; var i:integer; s:real;begin s:=1;write(s); for i:=1 to 50 do begin i:=i+1; s:=s*i;write('*',i); end; write (' = ',s); end. P.s. Программа написана на языке PascalABC, странный ответ она выдает потому, что в данном языке есть ограничения, и число, которое получается, выходит за диапазон данного значения.
1 votes Thanks 2
ЕнотЕнотыч
У меня АВс и выдают ошибку ) Тогда лучше с помощью if эт решить )
Answers & Comments
var i:integer;
s:real;begin
s:=1;write(s);
for i:=1 to 50 do begin
i:=i+1;
s:=s*i;write('*',i);
end;
write (' = ',s);
end.
P.s. Программа написана на языке PascalABC, странный ответ она выдает потому, что в данном языке есть ограничения, и число, которое получается, выходит за диапазон данного значения.
a:=50;