Найти средний рост 32 учеников . Нужно написать программу!
Answers & Comments
gorynych777
Var mas:array[1..32] of real; i,k:integer; sum:real; begin for i:= 1 to 32 do begin write('Введите рост ',i,' ученика'); readln(mas[i]) end; writeln; sum:=0; k:=0; for i:= 1 to 32 do begin sum:=sum+mas[i]; k:=k+1 end; write(sum/k) end.
0 votes Thanks 0
gorynych777
да ваша программа эффективнее по времени и по памяти. потому что вы данные сразу обрабатываете, а я их в массив ложу. да и зачем я переменную k вводит, если и так известно количество.
Answers & Comments
mas:array[1..32] of real;
i,k:integer;
sum:real;
begin
for i:= 1 to 32 do
begin write('Введите рост ',i,' ученика'); readln(mas[i]) end;
writeln;
sum:=0;
k:=0;
for i:= 1 to 32 do
begin sum:=sum+mas[i]; k:=k+1 end;
write(sum/k)
end.