Program n1; type z = array of integer; var a: z; i,n,max: integer; f: text; begin assign(f,'input.txt'); reset(f); n:=0; while not eof(f) do begin n:=n+1; setlength(a,n); read(f,a[n-1]); end; close(f); max:=a[0]; for i:= 1 to n-1 do if (a[i]>max) and(a[i] mod 2<>0) then max:=a[i]; assign(f,'output.txt'); rewrite(f); write(f,max); close(f); end.
AnonimusPro
так же количество чисел неизвестно, значит без динамического массива никак не обойтись
5polishka5
почему, у меня же есть файл input.txt , где записаны числа , и среди них надо найти это число
5polishka5
вы не могли бы написать программу таким способом?считая, что есть готовый текстовый файл с числами, среди которых это максимальное отрицательное нечетное число?
Answers & Comments
Verified answer
Program n1;type z = array of integer;
var a: z;
i,n,max: integer;
f: text;
begin
assign(f,'input.txt');
reset(f);
n:=0;
while not eof(f) do
begin
n:=n+1;
setlength(a,n);
read(f,a[n-1]);
end;
close(f);
max:=a[0];
for i:= 1 to n-1 do
if (a[i]>max) and(a[i] mod 2<>0) then max:=a[i];
assign(f,'output.txt');
rewrite(f);
write(f,max);
close(f);
end.