Написать программу, которая определяет максимальное число из введенной с клавиатуры последовательности чисел. Ниже представлен вид экрана во время работы программы:
Вводите последовательно числа.
Для завершения ввода введите ноль.
----------------------
1 число: 33
2 число: 45
3 число: -10
4 число: 0
----------------------
Максимальное число: 45
Answers & Comments
Verified answer
Vari, max, y: integer;begin
Writeln('Вводите последовательно числа.');
Writeln('Для завершения ввода введите ноль.');
Writeln('----------------------');
max := 0;
y := 0;
repeat
y := y + 1;
write(y, ' число:');
readln(i);
if (y = 1) then max := i;
if (i = 0) then break;
if (i > max) then max := i;
until i = 0;
Writeln('----------------------');
Writeln('Максимальное число: ', max);
Writeln();
end.
Var i,max,y:integer;
Begin
Writeln('Вводите последовательно числа.');
Writeln('Для завершения ввода введите ноль.');
Writeln('----------------------');
max:=0;
y:=0;
Repeat
y:=y+1;
write(y,' число:');
readln(i);
If (i<>0) then
Until i=0;
Writeln('----------------------');
Writeln('Максимальное число: ',);
Writeln();
End.