Написать программу, которая перед каждой маленькой английской буквой в строке вставит последовательность из английского алфавита, начиная с буквы «a» и до рассматриваемой буквы в строке. Перед буквой «a» в строке ничего ставить не надо. паскаль НЕ ИСПОЛЬЗОВАТЬ массивы и индексацию
Answers & Comments
Ответ:
На c# (не паскаль)
Объяснение:
using System;
namespace ConsoleApp2
{
class Program
{
static void Main(string[] args)
{
string InputString = "";
Console.Write("Введите строку: ");
InputString = Console.ReadLine();
foreach(char Sign in InputString)
{
if( Sign>='b' && Sign < 'z')
{
for(int i=(int)'a'; i <= (int)Sign; i++ )
{
Console.Write((char)i);
}
}
else Console.Write(Sign);
}
Console.WriteLine();
Console.ReadLine();
}
}
}
На паскеле в комментах ниже написал