Написать программу, которая запрашивает массив размерности N и выводит на экран сам массив, а также наибольший и наименьший элементы массива. Протестировать программу на массивах размерностью 5 и 10 элементов.
Answers & Comments
roookky
Var a:array [1..100] of integer; max, min, n, i:integer; begin readln(n); for i:=1 to n do read(a[i]); for i:=1 to 10 do write(a[i],' '); max:=-maxint; min:=maxint; for i:=1 to n do begin if a[i]>max then max:=a[i]; if a[i]<min then min:=a[i]; end; writeln('Наибольший элемент: ',max); writeln('Наименьший элемент: ',min) end.
saxila15
а можете еще вот эту:Написать программу, которая запрашивает массив из N элементов, а затем делит все элементы массива на минимальный элемент.
saxila15
1. Написать программу, которая сортирует массив из N элементов по возрастанию методом «пузырька» и считает при этом количество произведённых перестановок. Протестировать программу на следующих исходных данных: а) 2 5 1 6 4 10 4 2 б) 1 2 5 6 -4 0 11 12 в) 12 10 6 4 2 1 0
saxila15
1. Написать программу, которая сортирует массив из N элементов по убыванию методом «пузырька» и считает при этом количество произведённых перестановок. Протестировать программу на следующих исходных данных: а) 2 5 1 6 4 10 4 2 б) 1 2 5 6 4 0 11 12 в) 12 10 6 4 2 1 0
Answers & Comments
max, min, n, i:integer;
begin
readln(n);
for i:=1 to n do
read(a[i]);
for i:=1 to 10 do
write(a[i],' ');
max:=-maxint;
min:=maxint;
for i:=1 to n do begin
if a[i]>max then max:=a[i];
if a[i]<min then min:=a[i];
end;
writeln('Наибольший элемент: ',max);
writeln('Наименьший элемент: ',min)
end.