Home
О нас
Products
Services
Регистрация
Войти
Поиск
serzhsmirnov93
@serzhsmirnov93
March 2022
1
10
Report
Написать программу на Паскале для вычисления стоимости покупки, состоящей из нескольких тетрадей и такого же количества обложек к ним. Результат должен выводиться в денежном формате, например, 145руб. 30коп.
Please enter comments
Please enter your name.
Please enter the correct email address.
Agree to
terms of service
You must agree before submitting.
Send
Answers & Comments
Krusty76
Program n_5;
var
a, b: real;
c: integer;
begin
write('Введите стоимость тетради - '); readln (a);
write('Введите стоимость обложки - '); readln (b);
write('Введите кол-во тетрадей - '); readln (c);
if (a <= 0) or (b <= 0) or (c <= 0) then exit;
writeln;
write('ИТОГО: ', trunc(c * (a + b)), ' руб. ', round(((c * (a + b)) - (trunc(c * (a + b))))*100), ' коп.');
end.
2 votes
Thanks 1
Krusty76
В моём Паскале АВС.NET всё работает на ура. Спасибо за задачу, над разделением на рубли и копейки пришлось поломать голову)
serzhsmirnov93
Спасибо огромное! Все верно.
More Questions From This User
See All
serzhsmirnov93
March 2022 | 0 Ответы
reshite na paskale dannoe uravnenienomer 22 budu blagodaren
Answer
serzhsmirnov93
October 2021 | 0 Ответы
osushestvite prevrashenie po sheme napishite uravnenie reakcij fe fecl2 feoh2 f
Answer
рекомендуемые вопросы
rarrrrrrrr
August 2022 | 0 Ответы
o chem dolzhny pozabotitsya v pervuyu ochered vzroslye pri organizacionnom vyvoze n
danilarsentev
August 2022 | 0 Ответы
est dva stanka na kotoryh vypuskayut odinakovye zapchasti odin proizvodit a zapcha
myachina8
August 2022 | 0 Ответы
najti po grafiku otnoshenie v3v1 v otvetah napisano 9 no nuzhno reshenie
ydpmn7cn6w
August 2022 | 0 Ответы
Choose the correct preposition: 1.I am fond (out,of,from) literature. 2.where ar...
millermilena658
August 2022 | 0 Ответы
opredelite kak sozdavalas i kto sozdaval arabskoe gosudarstvo v kracii
MrZooM222
August 2022 | 0 Ответы
ch ajtmanov v rasskaze krasnoe yabloko ispolzuet metod rasskaz v rasskaze opi
timobila47
August 2022 | 0 Ответы
kakovo bylo naznachenie kazhdoj iz chastej vizantijskogo hrama pomogite pozhalujsta
ivanyyaremkiv
August 2022 | 0 Ответы
moment. 6....
pozhalujsta8b98a56c0152a07b8f4cbcd89aa2f01e 97513
sarvinozwakirjanova
August 2022 | 0 Ответы
pomogite pozhalusto pzha519d7eb8246a08ab0df06cc59e9dedb 6631
×
Report "Написать программу на Паскале для вычисления стоимости покупки, состоящей из нес..."
Your name
Email
Reason
-Select Reason-
Pornographic
Defamatory
Illegal/Unlawful
Spam
Other Terms Of Service Violation
File a copyright complaint
Description
Helpful Links
О нас
Политика конфиденциальности
Правила и условия
Copyright
Контакты
Helpful Social
Get monthly updates
Submit
Copyright © 2025 SCHOLAR.TIPS - All rights reserved.
Answers & Comments
var
a, b: real;
c: integer;
begin
write('Введите стоимость тетради - '); readln (a);
write('Введите стоимость обложки - '); readln (b);
write('Введите кол-во тетрадей - '); readln (c);
if (a <= 0) or (b <= 0) or (c <= 0) then exit;
writeln;
write('ИТОГО: ', trunc(c * (a + b)), ' руб. ', round(((c * (a + b)) - (trunc(c * (a + b))))*100), ' коп.');
end.