написать программу на паскале к задаче
Ученик 9 класса к уроку литературы должен выучить наизусть три первые строфы первой главы романа А, С. Пушкина «Евгений Онегин», содержащие 42 строки. Сколько ему потребуется времени на выполнение этого задания, если первую строку он может запомнить за 5 секунд, а на запоминание каждой следующей строки ему требуется времени на 2 секунды больше, чем на запоминание предыдущей строки?
Answers & Comments
Var str , time, thtime: integer;
Begin
str := 42;
thtime := 5;
While str>0 Do
Begin
str := str-1;
time := thtime+time;
thtime := thtime+2;
End;
write(time,' секунд');
End.