Написать программу на паскалеЕсли данное число х меньше нуля, то Z присвоить значение большего из 2 чисел х и у, иначе Z присвойте значение полсуммы этих чисел.
Program Z;
Uses Crt;
var x,y,z:real;
begin
clrscr;
write('Введите х: ');
readln(x);
write('Введите y: ');
readln(y);
if (x<0) and (x>y) then z:=x;
if (x<0) and (x<y) then z:=y;
if (x>=0) then z:=(x+y)/2;
writeln('z=',z);
readkey;
end.
Copyright © 2024 SCHOLAR.TIPS - All rights reserved.
Answers & Comments
Program Z;
Uses Crt;
var x,y,z:real;
begin
clrscr;
write('Введите х: ');
readln(x);
write('Введите y: ');
readln(y);
if (x<0) and (x>y) then z:=x;
if (x<0) and (x<y) then z:=y;
if (x>=0) then z:=(x+y)/2;
writeln('z=',z);
readkey;
end.