Написать программу на языке Pascal. Найти значение выражения для заданного x. 1.1. 2x+5; 1.2. 3x^2+1x+7; 1.3. 3x+7; 1.4. 2x^2+7+10 Знак ^ обозначает степень числа, а в паскале записывается как Sqr(x), где x переменная.
Answers & Comments
AwePlaxa
Var x:integer; begin x:= ;//Сюда ввести значение. writeln(2*x+5); writeln(3*Sqr(x)+1*x+7); writeln(3*x+7); writeln(2*sqr(x)+7+10); end.
С вводом X:
var x:integer; begin writeln('Введите x: '); readln(x); writeln(2*x+5); writeln(3*Sqr(x)+1*x+7); writeln(3*x+7); writeln(2*sqr(x)+7+10); end.
1 votes Thanks 1
SuperCode
Var x,i,a1,a2,a3,a4:integer; Begin readln(x); a1:=2*x+5; a2:=3*sqr(x)+x+7; a3:=3*x+7; a4:=2*sqr(x)+7+10; writeln(a1); writeln(a2); writeln(a3); writeln(a4); End.
1 votes Thanks 1
AwePlaxa
Зачем нагружать память компьютера таким количеством переменных?Конечно это не принципиально и нагрузка будет не значительной,но все же.
SuperCode
А что если эти данные понадобятся в будущем, нужно будет произвести ещё некоторые операции над получившимися числами.
AwePlaxa
Но тут же четкое задание дано.Тут не предусматриваются изменения.Поэтому такое кол-во переменных не требуется.
Answers & Comments
begin
x:= ;//Сюда ввести значение.
writeln(2*x+5);
writeln(3*Sqr(x)+1*x+7);
writeln(3*x+7);
writeln(2*sqr(x)+7+10);
end.
С вводом X:
var x:integer;
begin
writeln('Введите x: ');
readln(x);
writeln(2*x+5);
writeln(3*Sqr(x)+1*x+7);
writeln(3*x+7);
writeln(2*sqr(x)+7+10);
end.
x,i,a1,a2,a3,a4:integer;
Begin
readln(x);
a1:=2*x+5;
a2:=3*sqr(x)+x+7;
a3:=3*x+7;
a4:=2*sqr(x)+7+10;
writeln(a1);
writeln(a2);
writeln(a3);
writeln(a4);
End.