Написать программу, в которой массив из 10 элементов заполняется случайными числами в пределах от 0 до 99, выводится на экран, и найти в нем: 1. количество нечетных чисел (если таких нет, то сообщить об этом) 2. минимальное число Можно оформить в виде 2-х задач
Answers & Comments
Ответ:
1.
var a:array [1..10] of integer;
i,k:integer;
begin
k:=0;
write('Массив: ');
for i:=1 to 10 do
begin
a[i]:=random(100);
write(a[i]:4);
if a[i] mod 2 = 1 then k:=k+1
end;
writeln;
if k>0 then writeln ('Количество нечетных чисел равно ',k)
else writeln ('Нечетных чисел нет')
end.
2.
var a:array [1..10] of integer;
i,m:integer;
begin
m:=99;
write('Массив: ');
for i:=1 to 10 do
begin
a[i]:=random(100);
write(a[i]:4);
if a[i] < m then m:=a[i]
end;
writeln;
writeln ('min = ',m)
end.
Объяснение:
var a:array [1..10] of integer;
i,k,m:integer;
begin
k:=0;
m:=99;
write('Массив: ');
for i:=1 to 10 do
begin
a[i]:=random(100);
write(a[i]:4);
if a[i] mod 2 = 1 then k:=k+1;
if a[i] < m then m:=a[i]
end;
writeln;
if k>0 then writeln ('Количество нечетных чисел равно ',k)
else writeln ('Нечетных чисел нет');
writeln ('min = ',m)
end.
===== PascalABC.NET =====
begin
var a := ArrRandom(10, 0, 99);
a.Println;
var k := a.Count(p -> p.IsOdd);
if k = 0 then
Println('Нечетных чисел нет')
else
Println('Нечетных чисел:', k);
Println('Минимальное число:', a.Min)
end.