Написать программу вычисления площади и периметра трапеции. 90 БАЛЛОВ.
Answers & Comments
kazakofgeorge
Program TRAPECIYA; var x1, x2 ,y1, y2, P, S:real; begin writeln("Введите значение верхнего основания"); readln(y1); writeln("Введите значение нижнего основания"); readln(y2); writeln("Введите значение левой грани"); readln(x1); writeln("Введите значение правой стороны"); readln(x2); P:=y1+y2+x1+x2; S:=((y1+y2)/2)*sqrt(sqr(x1)-(sqr(sqr(y2-y1)+sqr(x1)-sqr(x2))/(2*(y2-y1))) writeln(P); writeln(S); end
Answers & Comments
var x1, x2 ,y1, y2, P, S:real;
begin
writeln("Введите значение верхнего основания");
readln(y1);
writeln("Введите значение нижнего основания");
readln(y2);
writeln("Введите значение левой грани");
readln(x1);
writeln("Введите значение правой стороны");
readln(x2);
P:=y1+y2+x1+x2;
S:=((y1+y2)/2)*sqrt(sqr(x1)-(sqr(sqr(y2-y1)+sqr(x1)-sqr(x2))/(2*(y2-y1)))
writeln(P);
writeln(S);
end