Напишите на Паскале программу, которая запрашивает с клавиатуры массив из N чисел, а затем выводит среднее арифметическое всех элементов массива.
Answers & Comments
Pashq4
Var n, i, sum: integer; a: array[1..100] of integer; average: real; begin write('Сколько чисел будет в массиве? '); readln(n); sum := 0; for i := 1 to n do begin write('Введите ', i, ' число: '); readln(a[i]); sum := sum + a[i]; end; average := sum/n; writeln('Среднее арифметическое: ', average); end.
shchspb
а, понял, переменная. Но в задании написано массив из N чисел, а у тебя программа до 100. Когда делаю до N, он мне пишет неизвестный идентификатор
Pashq4
Верно. Потому что N не определенно. Это Паскаль, а не С++
Pashq4
Можешь сделать массив из 1000. Но все равно ты вряд ли станешь столько вводить
shchspb
То есть нельзя сделать, чтобы я сам вводил с клавиатуры, сколько чисел я хочу ввести? А если я хочу ввести например 2 числа, а не 100?
Pashq4
Сто чисел вводить и не нужно. Для этого и используется N - чтобы указать кол-во чисел, которые надо ввести. 100 - это максимум, который можно указать. Если вы все же хотите сами ввести максимальное значение, то используйте динамический массив
Answers & Comments
a: array[1..100] of integer;
average: real;
begin
write('Сколько чисел будет в массиве? ');
readln(n);
sum := 0;
for i := 1 to n do
begin
write('Введите ', i, ' число: ');
readln(a[i]);
sum := sum + a[i];
end;
average := sum/n;
writeln('Среднее арифметическое: ', average);
end.