Напишите программу для решения следующей задачи. Камера наблюдения регистрирует в автоматическом режиме скорость проезжающих мимо неё автомобилей, округляя значение до целых чисел. Необходимо определить :
Answers & Comments
pokemanbr
Program a18; var a,max,min,kol:integer; begin readln(a); max:=a; min:=a; kol:=0; while(a<>0) do begin if(a>max) then max:=a; if(a<min) then min:=a; if(a>120) then inc(kol); readln(a); end; writeln(max-min); writeln(kol); end.
Answers & Comments
var
a,max,min,kol:integer;
begin
readln(a);
max:=a;
min:=a;
kol:=0;
while(a<>0) do begin
if(a>max) then max:=a;
if(a<min) then min:=a;
if(a>120) then inc(kol);
readln(a);
end;
writeln(max-min);
writeln(kol);
end.