Напишите программу к задаче вообще не понимаю! Заранее спасибо!!! Поставлю ответ лучшим! Шоколадка стоит a рублей с копеек. Какое наибольшее количество шоколадок можно купить за b рублей?
Program program1; var a, b, c, n: integer; begin writeln('Введите стоимость шоколадки:'); write('рублей и копеек через пробел: '); readln(a, c); write('Введите количество рублей, которые имеются у Вас: '); readln(b); if (a < 0) or (c < 0) or (c > 99) then writeln('введите корректные данные') else begin n := trunc(b / (a + c/100)); writeln(n, ' шоколадок'); end; end.
Answers & Comments
Verified answer
Program program1;var
a, b, c, n: integer;
begin
writeln('Введите стоимость шоколадки:');
write('рублей и копеек через пробел: ');
readln(a, c);
write('Введите количество рублей, которые имеются у Вас: ');
readln(b);
if (a < 0) or (c < 0) or (c > 99) then
writeln('введите корректные данные')
else
begin
n := trunc(b / (a + c/100));
writeln(n, ' шоколадок');
end;
end.