Напишите программу, которая будет генерировать список случайных чисел в
диапазоне от 1 до 100. Длина списка тоже должна быть случайной в диапазоне от
10 до 20. Потом программа должна найти в этом списке все элементы, меньшие
заданного пользователем значения, сформировать из них новый список и
напечатать первоначальный и полученный списки.
Answers & Comments
class Task {
public static void main(String[] args) {
List<Integer> numbers = new ArrayList<>();
Random rand = new Random();
int length = rand.nextInt(11)+10;
for(int i=0; i<length; i++)
numbers.add(rand.nextInt(100)+1);
int number = new Scanner(System.in).nextInt();
List<Integer> newNumbers = new ArrayList<>();
for(Integer num : numbers)
if(num<number)
newNumbers.add(num);
System.out.println(numbers+"\n" +newNumbers);
}
}
//также все используемые классы и пакеты необходимо импортировать