Напишите программу, которая будет проверять есть ли любимое блюдо пользователя в меню.
Пользователь вводит блюдо, а программа с помощью цикла for проверяет, есть ли оно в списке menu.
Если блюдо есть, то программа выводит сообщение: “Это блюдо есть в меню!”
menu = ["Пицца", "Паста", "Борщ", "Пельмени"]
prod = input("Введите любимое блюдо:")
Answers & Comments
#include <iostream>
#include <string>
#include <Windows.h>
using namespace std;
int main()
{
SetConsoleCP(1251);
SetConsoleOutputCP(1251);
string menu[4] = { "Пицца", "Паста", "Борщ", "Пельмени" };
string dish;
cout << "Введите любимое блюдо: "; //если ввести название блюда с маленькой буквы то выведет неправильный ответ
getline(cin, dish);
for (int z = 0; z < 4; z++)
if (menu[z] == dish)
cout << "Это блюдо есть в меню!";
}