Напишите программу, которая определяет, попала ли точка с заданными координатами в заштрихованную область
Входные данные
Входная строка содержит два вещественных числа – координаты точки на плоскости (сначала x -координата, затем – y -координата).
Выходные данные
Программа должна вывести слово 'YES', если точка попала в заштрихованную область, и слово 'NO', если не попала.
входные данные
0. 1.
выходные данные
NO
входные данные
0. -1.
выходные данные
YES
На языке программирования, удобном для вас
Answers & Comments
var
x, y: real;
begin
read(x, y);
if (y > sqr(x)-2) and ((y < x) or (y < -x)) then
writeln('YES')
else
writeln('NO')
end.