Напишите программу, которая просит пользователя ввести целое число N и M, которые являются количеством строк и столбцов для массива. Программа должна предложить пользователю ввести NxM целых чисел и хранить их в двумерном массиве. Затем программа должна вывести общее количество отрицательных элементов в каждой строке.
Решение задачи C++
Answers & Comments
Ответ:
#include <iostream>
using namespace std;
int main()
{ int n,m,c=0;
cin >> n >> m;
int a[n*m];
for(int i=0;i<n*m;i++)
cin >> a[i];
for(int i=0;i<n*m;i++){
if(a[i]<0) c++;
if((i+1)%m==0 && i!=0){
cout << c << endl;
c=0;
}
}
return 0;
}
Объяснение: