напишите программу, которая в последовательности целых чисел определяет их сумму и количество четных чисел, кратных 5. Программа получает на вход целые числа, количество введенных чисел неизвестно, последовательность чисел заканчивается число 0(0-признак окончания ввода, не входит в последовательность СРОЧНО, ПОЖАЛУЙСТА, НА ПАСКАЛЕ
Answers & Comments
var i,n,k: integer;
s: longint;
begin
s :=0; k :=0;
repeat
readln ( i );
s:=s+i;
if ( i <> 0) and ( i mod 2=0) and ( i mod 5=0) then k:=k+1;
until i=0;
writeln ('s= ',s, ' ', 'k= ',k);
end.